You are viewing this site as a guest. You can still ask questions and help others! Join our Dev2Dev IT Community to receive your own blog, share your knowledge, and much more.

Query Not running online

3 replies [Last post]
Guest's picture
Guest

Hello All,

I am getting the below error when I try to run the *public query SAR_TER_BY_DATE* online using Query Manager.

**[Open Query] [CQryStmt::Prepare] QDM could not load query definition [ PUBLIC.SAR_TER_BY_DATE ]**

I checked the all PSQUERY tables like PSQRYDEFN, PSQRYFIELD, PSQRYEXPR, PSQRYCRITERIA, PSQRYRECORD, PSQRYSELECT etc and this query exist in all the PSQUERY tables. I am able to run in two-tie and in database using query tool.

Please let me know what could be the problem.

Thanks in Advance!

Lepa's picture
User offline. Last seen 2 years 2 weeks ago. Offline
Joined: 06/23/2008
Posts: 591
Re: Query Not running online

Has any of the underlying tables behind your SAR_TER_BY_DATE query changed/modified? Try using "save as" and try running the new query online. Let me know how it goes.

Give back to the community and help it grow!
* Help with unanswered forum questions and issues
* Register or login to share your knowledge at your own blog

Guest's picture
Guest (not verified)
Re: Query Not running online

Thanks Lepa!!! It worked perfectly. Thanks for helping community.

Lepa's picture
User offline. Last seen 2 years 2 weeks ago. Offline
Joined: 06/23/2008
Posts: 591
Re: Query Not running online

Your welcome, its a weird issue and sometimes just re-saving the query would do the trick. Glad its working now.

Give back to the community and help it grow!
* Help with unanswered forum questions and issues
* Register or login to share your knowledge at your own blog